[PATCH] mm/page_alloc: Replace flag check with PageHWPoison() in check_new_page_bad()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: Ye Liu <liuye@xxxxxxxxxx>

This patch replaces the direct check for the __PG_HWPOISON flag with
the PageHWPoison() macro, improving code readability and maintaining
consistency with other parts of the memory management code.

Signed-off-by: Ye Liu <liuye@xxxxxxxxxx>
---
 mm/page_alloc.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/mm/page_alloc.c b/mm/page_alloc.c
index fe76fd237dd0..6ef54abebf51 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -1427,7 +1427,7 @@ static __always_inline void page_del_and_expand(struct zone *zone,
 
 static void check_new_page_bad(struct page *page)
 {
-	if (unlikely(page->flags & __PG_HWPOISON)) {
+	if (unlikely(PageHWPoison(page))) {
 		/* Don't complain about hwpoisoned pages */
 		if (PageBuddy(page))
 			__ClearPageBuddy(page);
-- 
2.25.1





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux