Hi Oleg On Wed, Feb 26, 2025 at 10:21 AM Oleg Nesterov <oleg@xxxxxxxxxx> wrote: > > On 02/26, Lorenzo Stoakes wrote: > > > > Like I said, Jeff opposes the change. I disagree with him, and agree with you, > > because this is very silly. > > > > But I don't want to hold up this series with that discussion (this is for his > > sake...) > > Neither me, so lets go with VM_SEALED_SYSMAP. > > My only objection is that > > vm_flags = VM_EXEC|VM_MAYEXEC|VM_DONTCOPY|VM_IO; > vm_flags |= VM_SEALED_SYSMAP; > > looks unnecessarily confusing to me, > > vm_flags = VM_EXEC|VM_MAYEXEC|VM_DONTCOPY|VM_IO|VM_SEALED_SYSMAP; > > or just > > vma = _install_special_mapping(..., > VM_EXEC|VM_MAYEXEC|VM_DONTCOPY|VM_IO|VM_SEALED_SYSMAP, > Sure ... > > looks more readable. But this is cosmetic/subjective, so I won't argue/insist. > > > Jeff - perhaps drop this and let's return to it in a follow up so this series > > isn't held up? > > Up to you and Jeff. > > But this patch looks "natural" to me in this series. > Thanks for sharing your insights on uprobe! Your expertise is invaluable. -Jeff > Oleg. >