Re: [PATCH mm-unstable 1/2] mm/mm_init: rename __init_reserved_page_zone to __init_page_from_nid

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Feb 25, 2025 at 10:30:16AM +0200, Mike Rapoport wrote:
>From: "Mike Rapoport (Microsoft)" <rppt@xxxxxxxxxx>
>
>__init_reserved_page_zone() function finds the zone for pfn and nid and
>performs initialization of a struct page with that zone and nid.
>There is nothing in that function about reserved pages and it is
>misnamed.
>
>Rename it to __init_page_from_nid() to better reflect what the function
>does.
>
>Signed-off-by: Mike Rapoport (Microsoft) <rppt@xxxxxxxxxx>

Reviewed-by: Wei Yang <richard.weiyang@xxxxxxxxx>

-- 
Wei Yang
Help you, Help me




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux