On Fri, 2025-02-14 at 11:55 -0800, Dave Hansen wrote: > > Fair enough. If we don't have a better name, we can at least do: > > if (new_bad_name()) { > new_thing(); > } else { > old_thing(); > } > > My real heartburn is with: > > if (new_bad_name()) { > new_thing(); > } else if (need_thing_1()) { > old_thing1(); > } else { > old_thing2(); > } > > Where new and old are logically squished together. > Do we want to group this code by history, or by function? I would argue that new_thing() and old_thing1() are closer to each other functionally (they both do remote TLB invalidation) than they are to old_thing2(), which does local-only invalidation. I can organize the code however people want, but I would like a second opinion on this idea :) -- All Rights Reversed.