On 14.02.25 07:35, Gavin Shan wrote:
It's unnecessary to keep the variable @section_count in the function
because the device for the specific memory block will be added if
any of its memory section is present. The variable @section_count
records the number of present memory sections in the specific memory
block, which isn't needed.
Simplify the function by dropping the variable @section_count. No
functional change intended.
Signed-off-by: Gavin Shan <gshan@xxxxxxxxxx>
---
drivers/base/memory.c | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)
diff --git a/drivers/base/memory.c b/drivers/base/memory.c
index 348c5dbbfa68..208b9b544012 100644
--- a/drivers/base/memory.c
+++ b/drivers/base/memory.c
@@ -822,18 +822,17 @@ static int add_memory_block(unsigned long block_id, unsigned long state,
static int __init add_boot_memory_block(unsigned long base_section_nr)
{
- int section_count = 0;
unsigned long nr;
for (nr = base_section_nr; nr < base_section_nr + sections_per_block;
- nr++)
- if (present_section_nr(nr))
- section_count++;
+ nr++) {
+ if (present_section_nr(nr)) {
+ return add_memory_block(memory_block_id(base_section_nr),
+ MEM_ONLINE, NULL, NULL);
+ }
Superfluous set of braces for the if statement.
Not sure I count this while thing here as a "simplifcation" -- the code
is IMHO easier to read without the nested return in the loop body.
No strong opinion, though.
--
Cheers,
David / dhildenb