On 2/13/25 16:53, Steven Price wrote: > On 13/02/2025 04:09, Anshuman Khandual wrote: >> Platforms subscribe into generic ptdump implementation via GENERIC_PTDUMP. >> But generic ptdump gets enabled via PTDUMP_CORE. These configs combination >> is confusing as they sound very similar and does not differentiate between >> platform's feature subscription and feature enablement for ptdump. Rename >> the configs as ARCH_HAS_PTDUMP and PTDUMP making it more clear and improve >> readability. > > I'm not going to bikeshed over the naming, but a few points below. > >> Cc: Catalin Marinas <catalin.marinas@xxxxxxx> >> Cc: Will Deacon <will@xxxxxxxxxx> >> Cc: Jonathan Corbet <corbet@xxxxxxx> >> Cc: Marc Zyngier <maz@xxxxxxxxxx> >> Cc: Michael Ellerman <mpe@xxxxxxxxxxxxxx> >> Cc: Nicholas Piggin <npiggin@xxxxxxxxx> >> Cc: Paul Walmsley <paul.walmsley@xxxxxxxxxx> >> Cc: Palmer Dabbelt <palmer@xxxxxxxxxxx> >> Cc: Heiko Carstens <hca@xxxxxxxxxxxxx> >> Cc: Vasily Gorbik <gor@xxxxxxxxxxxxx> >> Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx> >> Cc: Ingo Molnar <mingo@xxxxxxxxxx> >> Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> >> Cc: linux-arm-kernel@xxxxxxxxxxxxxxxxxxx >> Cc: linux-doc@xxxxxxxxxxxxxxx >> Cc: linux-kernel@xxxxxxxxxxxxxxx >> Cc: kvmarm@xxxxxxxxxxxxxxx >> Cc: linuxppc-dev@xxxxxxxxxxxxxxxx >> Cc: linux-riscv@xxxxxxxxxxxxxxxxxxx >> Cc: linux-s390@xxxxxxxxxxxxxxx >> Cc: linux-mm@xxxxxxxxx >> Signed-off-by: Anshuman Khandual <anshuman.khandual@xxxxxxx> >> --- >> Documentation/arch/arm64/ptdump.rst | 4 ++-- >> arch/arm64/Kconfig | 2 +- >> arch/arm64/include/asm/ptdump.h | 4 ++-- >> arch/arm64/kvm/Kconfig | 4 ++-- >> arch/arm64/mm/Makefile | 2 +- >> arch/powerpc/Kconfig | 2 +- >> arch/powerpc/configs/mpc885_ads_defconfig | 2 +- >> arch/powerpc/mm/Makefile | 2 +- >> arch/riscv/Kconfig | 2 +- >> arch/riscv/mm/Makefile | 2 +- >> arch/s390/Kconfig | 2 +- >> arch/s390/mm/Makefile | 2 +- >> arch/x86/Kconfig | 2 +- >> arch/x86/Kconfig.debug | 2 +- >> arch/x86/mm/Makefile | 2 +- >> mm/Kconfig.debug | 12 ++++++------ >> mm/Makefile | 2 +- >> 17 files changed, 25 insertions(+), 25 deletions(-) >> >> diff --git a/Documentation/arch/arm64/ptdump.rst b/Documentation/arch/arm64/ptdump.rst >> index 5dcfc5d7cddf..a2e527377da3 100644 >> --- a/Documentation/arch/arm64/ptdump.rst >> +++ b/Documentation/arch/arm64/ptdump.rst >> @@ -22,8 +22,8 @@ offlining of memory being accessed by the ptdump code. >> In order to dump the kernel page tables, enable the following >> configurations and mount debugfs:: >> >> - CONFIG_GENERIC_PTDUMP=y >> - CONFIG_PTDUMP_CORE=y >> + CONFIG_ARCH_HAS_PTDUMP=y >> + CONFIG_PTDUMP=y >> CONFIG_PTDUMP_DEBUGFS=y > > I think we should drop CONFIG_GENERIC_PTDUMP/CONFIG_ARCH_HAS_PTDUMP from > this list. It's not a user-selectable symbol so there's no need to be > documenting it here. Sure, will fold that in here. > >> >> mount -t debugfs nodev /sys/kernel/debug > [...] >> diff --git a/arch/powerpc/configs/mpc885_ads_defconfig b/arch/powerpc/configs/mpc885_ads_defconfig >> index 77306be62e9e..db005618690b 100644 >> --- a/arch/powerpc/configs/mpc885_ads_defconfig >> +++ b/arch/powerpc/configs/mpc885_ads_defconfig >> @@ -78,4 +78,4 @@ CONFIG_DEBUG_VM_PGTABLE=y >> CONFIG_DETECT_HUNG_TASK=y >> CONFIG_BDI_SWITCH=y >> CONFIG_PPC_EARLY_DEBUG=y >> -CONFIG_GENERIC_PTDUMP=y >> +CONFIG_PTDUMP=y > > I'd suggest dropp this from the defconfig too, just like patch 1 dropped > it from debug.config. Agreed.