Le 13/02/2025 à 12:23, Steven Price a écrit :
On 13/02/2025 04:09, Anshuman Khandual wrote:
Platforms subscribe into generic ptdump implementation via GENERIC_PTDUMP.
But generic ptdump gets enabled via PTDUMP_CORE. These configs combination
is confusing as they sound very similar and does not differentiate between
platform's feature subscription and feature enablement for ptdump. Rename
the configs as ARCH_HAS_PTDUMP and PTDUMP making it more clear and improve
readability.
[...]
diff --git a/arch/powerpc/configs/mpc885_ads_defconfig b/arch/powerpc/configs/mpc885_ads_defconfig
index 77306be62e9e..db005618690b 100644
--- a/arch/powerpc/configs/mpc885_ads_defconfig
+++ b/arch/powerpc/configs/mpc885_ads_defconfig
@@ -78,4 +78,4 @@ CONFIG_DEBUG_VM_PGTABLE=y
CONFIG_DETECT_HUNG_TASK=y
CONFIG_BDI_SWITCH=y
CONFIG_PPC_EARLY_DEBUG=y
-CONFIG_GENERIC_PTDUMP=y
+CONFIG_PTDUMP=y
I'd suggest dropp this from the defconfig too, just like patch 1 dropped
it from debug.config.
Thanks for spotting that.
That one is wrong. Was introduced by commit d210ee3fdfe8
("powerpc/configs: Update config files for removed/renamed symbols")
which aimed at fixing commit e084728393a5 ("powerpc/ptdump: Convert
powerpc to GENERIC_PTDUMP") but it did it wrong.
It is CONFIG_PTDUMP_DEBUGFS that is wanted.