Hi Ackerley, On Wed, 12 Feb 2025 at 00:15, Ackerley Tng <ackerleytng@xxxxxxxxxx> wrote: > > Fuad Tabba <tabba@xxxxxxxxxx> writes: > > > For VMs that allow sharing guest_memfd backed memory in-place, > > handle that memory the same as "private" guest_memfd memory. This > > means that faulting that memory in the host or in the guest will > > go through the guest_memfd subsystem. > > > > Note that the word "private" in the name of the function > > kvm_mem_is_private() doesn't necessarily indicate that the memory > > isn't shared, but is due to the history and evolution of > > guest_memfd and the various names it has received. In effect, > > this function is used to multiplex between the path of a normal > > page fault and the path of a guest_memfd backed page fault. > > > > Thanks for this summary! It has always been confusing and this really > helps. > > Is there any chance we could rename the functions in KVM, or maybe add a > comment at the function definitions? The name of the userspace flag will > have to remain, of course. Actually, I was thinking of doing that in V4. Rename, or at least add an alias, as a separate patch, to see what the community thinks. Since, even with this comment, it is still confusing (as evidenced by Quentin's comment on the later patch). Cheers, /fuad > > Signed-off-by: Fuad Tabba <tabba@xxxxxxxxxx> > > --- > > include/linux/kvm_host.h | 3 ++- > > 1 file changed, 2 insertions(+), 1 deletion(-) > > > > diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h > > index 438aa3df3175..39fd6e35c723 100644 > > --- a/include/linux/kvm_host.h > > +++ b/include/linux/kvm_host.h > > @@ -2521,7 +2521,8 @@ static inline bool kvm_mem_is_private(struct kvm *kvm, gfn_t gfn) > > #else > > static inline bool kvm_mem_is_private(struct kvm *kvm, gfn_t gfn) > > { > > - return false; > > + return kvm_arch_gmem_supports_shared_mem(kvm) && > > + kvm_slot_can_be_private(gfn_to_memslot(kvm, gfn)); > > } > > #endif /* CONFIG_KVM_GENERIC_MEMORY_ATTRIBUTES */