On Thu, 23 Jan 2025 at 11:42, David Hildenbrand <david@xxxxxxxxxx> wrote: > > On 22.01.25 16:27, Fuad Tabba wrote: > > Add the KVM capability KVM_CAP_GUEST_MEMFD_MAPPABLE, which is > > true if mapping guest memory is supported by the host. > > > > Signed-off-by: Fuad Tabba <tabba@xxxxxxxxxx> > > --- > > include/uapi/linux/kvm.h | 1 + > > virt/kvm/kvm_main.c | 4 ++++ > > 2 files changed, 5 insertions(+) > > > > diff --git a/include/uapi/linux/kvm.h b/include/uapi/linux/kvm.h > > index 502ea63b5d2e..021f8ef9979b 100644 > > --- a/include/uapi/linux/kvm.h > > +++ b/include/uapi/linux/kvm.h > > @@ -933,6 +933,7 @@ struct kvm_enable_cap { > > #define KVM_CAP_PRE_FAULT_MEMORY 236 > > #define KVM_CAP_X86_APIC_BUS_CYCLES_NS 237 > > #define KVM_CAP_X86_GUEST_MODE 238 > > +#define KVM_CAP_GUEST_MEMFD_MAPPABLE 239 > > Maybe similarly consider calling this something like > > KVM_CAP_GUEST_MEMFD_SHARED_MEM > > No strong opinion on this one, though. Ack. That would make the naming consistent. /fuad > -- > Cheers, > > David / dhildenb >