[PATCH v3 next 0/5] Some cleanup for memcg

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: Chen Ridong <chenridong@xxxxxxxxxx>

Some cleanup for memcg

---

v2->v3:
 - move the wrapper function definitions to header files.
 - add a patch to move the 'local' functions to the memcontrol-v1.c.

v1->v2:
 - drop the patch 'simplify the mem_cgroup_update_lru_size function'.
 - for patch 3, rename '__refill_obj_stock' to replace_stock_objcg, and
   keep the 'objcg equal' check in the calling functions.

Chen Ridong (5):
  memcg: use OFP_PEAK_UNSET instead of -1
  memcg: call the free function when allocation of pn fails
  memcg: factor out the replace_stock_objcg function
  memcg: factor out stat(event)/stat_local(event_local) reading
    functions
  memcg: move the 'local' functions to memcontrol-v1.c

 include/linux/memcontrol.h |  25 +++++--
 mm/memcontrol-v1.c         |  17 +++++
 mm/memcontrol-v1.h         |  11 ++--
 mm/memcontrol.c            | 130 ++++++++++++-------------------------
 4 files changed, 86 insertions(+), 97 deletions(-)

-- 
2.34.1





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux