On Tue, Jan 14, 2025 at 05:54:15PM -0800, John Hubbard wrote: > On 1/14/25 7:48 AM, Lorenzo Stoakes wrote: > > On Mon, Jan 13, 2025 at 10:53:33AM +0100, Alice Ryhl wrote: > > > On Mon, Dec 16, 2024 at 3:50 PM Andreas Hindborg <a.hindborg@xxxxxxxxxx> wrote: > > > > "Alice Ryhl" <aliceryhl@xxxxxxxxxx> writes: > ... > > > > > +/// [`mmget_not_zero`]: Mm::mmget_not_zero > > > > > +#[repr(transparent)] > > > > > +pub struct Mm { > > > > > > > > Could we come up with a better name? `MemoryMap` or `MemoryMapping`?. You > > > > use `MMapReadGuard` later. > > > > > > Those names seem really confusing to me. The mmap syscall creates a > > > new VMA, but MemoryMap sounds like it's the thing that mmap creates. > > > > > > Lorenzo, what do you think? I'm inclined to just call it Mm since > > > that's what C calls it. > > > > I think Mm is better just for aligment with the C stuff, I mean the alternative > > is MmStruct or something and... yuck. > > For what it's worth, I think using the C naming here is a very good approach. > Because if you come up with a "good" name that is different than what C has > been calling it for 30+ years, then we have to be very thorough in associating > that new name with the C name. And it's hard. 100% agree! > > And "mm struct" goes waaay back. Just use that name and everyone will know > what it means. > > For less well-established areas, with fewer callers, there is much more > freedom to come up with new, better names. > > > > > And like, here I am TOTALLY onboard with Andreas here, because this naming > > SUCKS. But it sucks on the C side too (we're experts at bad naming :). So for > > consistency, let's suck everywhere... > > > > Feel free to put a comment about this being a bad name if you like > > though... (not obligatory :) > > For mm struct? Maybe let's not! Explanation without the criticism seems > more appropriate imho. :) ;) Well one could phrase this in a relatifvely benign way for instance 'while this name may seem a little unclear, historically it has been used as a shorthand within the kernel for time immemorial' or such. > > btw, I'm very excited to see all of this Rust for Linux progress, it is > wonderful! Thank you for this! +1 to this sentiment, am very happy to try to do my best to add value to get this series in as - from my perspective - I want the compiler to tell me when I make mistakes nice and early :)) Thanks Alice, Andreas and all involved! > > > thanks, > -- > John Hubbard >