Re: [PATCHSET v7 0/11] Uncached buffered IO

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 12/20/24 4:25 AM, Kirill A. Shutemov wrote:
>> Since v6
>> - Rename the PG_uncached flag to PG_dropbehind
>> - Shuffle patches around a bit, most notably so the foliop_uncached
>>   patch goes with the ext4 support
>> - Get rid of foliop_uncached hack for btrfs (Christoph)
>> - Get rid of passing in struct address_space to filemap_create_folio()
>> - Inline invalidate_complete_folio2() in folio_unmap_invalidate() rather
>>   than keep it as a separate helper
>> - Rebase on top of current master
> 
> Hm. v6 had a patch that cleared the PG_uncached flag if the page accessed
> via non-uncached lookup[1]. What happened to it? I don't see it here.
> 
> https://lore.kernel.org/all/20241203153232.92224-14-axboe@xxxxxxxxx

Since I only needed these bits for the fs support, I didn't include it in
this series. However, I did move it back to the core series for v8, it's
this one:

https://git.kernel.dk/cgit/linux/commit/?h=buffered-uncached.10&id=e4b7e8f693caf84021424ebafa139f38c5599db3

to avoid having a core dependency for the patches adding support to
iomap and xfs/btrfs.

I'll send out a new version with just slight tweaks today. So far it
has the following changelog:

- Rename filemap_uncached_read() to filemap_end_dropbehind_read()
- Rename folio_end_dropbehind() to folio_end_dropbehind_write()
- Make the "mm: add FGP_DONTCACHE folio creation flag" patch part of
  the base patches series, to avoid dependencies with btrfs/xfs/iomap
- Remove now dead IOMAP_F_DONTCACHE define and setting on xfs/iomap

where moving this patch back to teh core series is one of the entries.

-- 
Jens Axboe




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux