On 2 Dec 2024, at 7:58, David Hildenbrand wrote: > In the __GFP_CONT case, we already pass the gfp_flags to s/__GFP_CONT/__GFP_COMP/ > prep_new_page()->post_alloc_hook(). However, in the !__GFP_CONT case, we Ditto > essentially pass only hardcoded __GFP_MOVABLE to post_alloc_hook(), > preventing some action modifiers from being effective.. > > Let's pass our now properly adjusted gfp flags there as well. > > This way, we can now support __GFP_ZERO for alloc_contig_*(). > > As a side effect, we now also support __GFP_SKIP_ZERO and__GFP_ZEROTAGS; > but we'll keep the more special stuff (KASAN, NOLOCKDEP) disabled for > now. > > It's worth nothing that with __GFP_ZERO, we might unnecessarily zero pages s/nothing/noting/ > when we have to release part of our range using free_contig_range() again. > This can be optimized in the future, if ever required; the caller we'll > be converting (powernv/memtrace) next won't trigger this. > > Signed-off-by: David Hildenbrand <david@xxxxxxxxxx> > --- > mm/page_alloc.c | 9 +++++---- > 1 file changed, 5 insertions(+), 4 deletions(-) > After the commit log is fixed, Reviewed-by: Zi Yan <ziy@xxxxxxxxxx> Best Regards, Yan, Zi