On 2024/11/13 01:00, David Hildenbrand wrote:
On 31.10.24 09:13, Qi Zheng wrote:
This commit introduces do_zap_pte_range() to actually zap the PTEs, which
will help improve code readability and facilitate secondary checking of
the processed PTEs in the future.
No functional change.
Signed-off-by: Qi Zheng <zhengqi.arch@xxxxxxxxxxxxx>
---
mm/memory.c | 45 ++++++++++++++++++++++++++-------------------
1 file changed, 26 insertions(+), 19 deletions(-)
diff --git a/mm/memory.c b/mm/memory.c
index bd9ebe0f4471f..c1150e62dd073 100644
--- a/mm/memory.c
+++ b/mm/memory.c
@@ -1657,6 +1657,27 @@ static inline int zap_nonpresent_ptes(struct
mmu_gather *tlb,
return nr;
}
+static inline int do_zap_pte_range(struct mmu_gather *tlb,
+ struct vm_area_struct *vma, pte_t *pte,
+ unsigned long addr, unsigned long end,
+ struct zap_details *details, int *rss,
+ bool *force_flush, bool *force_break)
+{
+ pte_t ptent = ptep_get(pte);
+ int max_nr = (end - addr) / PAGE_SIZE;
+
+ if (pte_none(ptent))
+ return 1;
Maybe we should just skip all applicable pte_none() here directly.
Do you mean we should keep pte_none() case in zap_pte_range()? Like
below:
diff --git a/mm/memory.c b/mm/memory.c
index 002aa4f454fa0..2ccdcf37b7a46 100644
--- a/mm/memory.c
+++ b/mm/memory.c
@@ -1666,9 +1666,6 @@ static inline int do_zap_pte_range(struct
mmu_gather *tlb,
pte_t ptent = ptep_get(pte);
int max_nr = (end - addr) / PAGE_SIZE;
- if (pte_none(ptent))
- return 1;
-
if (pte_present(ptent))
return zap_present_ptes(tlb, vma, pte, ptent, max_nr,
addr, details, rss, force_flush,
@@ -1704,11 +1701,15 @@ static unsigned long zap_pte_range(struct
mmu_gather *tlb,
if (need_resched())
break;
- nr = do_zap_pte_range(tlb, vma, pte, addr, end, details,
rss,
- &force_flush, &force_break);
- if (unlikely(force_break)) {
- addr += nr * PAGE_SIZE;
- break;
+ if (pte_none(ptep_get(pte))) {
+ nr = 1;
+ } else {
+ nr = do_zap_pte_range(tlb, vma, pte, addr, end,
details,
+ rss, &force_flush,
&force_break);
+ if (unlikely(force_break)) {
+ addr += nr * PAGE_SIZE;
+ break;
+ }
}
} while (pte += nr, addr += PAGE_SIZE * nr, addr != end);
This avoids repeated checks for pte_none() later. Both are fine for
me, will change to this in the next version.
Acked-by: David Hildenbrand <david@xxxxxxxxxx>
Thanks!