On 11/1/24 13:04, Muhammad Usama Anjum wrote: > On 11/1/24 4:15 PM, Mirsad Todorovac wrote: >> Coccinelle gives WARNING recommending the use of ARRAY_SIZE() macro definition >> to improve the code readability: >> >> ./tools/testing/selftests/x86/syscall_numbering.c:316:35-36: WARNING: Use ARRAY_SIZE >> >> Fixes: 15c82d98a0f78 ("selftests/x86/syscall: Update and extend syscall_numbering_64") >> Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx> >> Cc: Ingo Molnar <mingo@xxxxxxxxxx> >> Cc: Borislav Petkov <bp@xxxxxxxxx> >> Cc: Dave Hansen <dave.hansen@xxxxxxxxxxxxxxx> >> Cc: x86@xxxxxxxxxx >> Cc: "H. Peter Anvin" <hpa@xxxxxxxxx> >> Cc: Shuah Khan <shuah@xxxxxxxxxx> >> Cc: linux-kernel@xxxxxxxxxxxxxxx >> Cc: linux-kselftest@xxxxxxxxxxxxxxx >> Signed-off-by: Mirsad Todorovac <mtodorovac69@xxxxxxxxx> > Reviewed-by: Muhammad Usama Anjum <usama.anjum@xxxxxxxxxxxxx> Dear Sir, Thank you for your positive review of the patch. There are much more suggestions by the coccinelle check, but that's a substantial work to do. It would help to set some priorities in this by some more experienced developer. Thank you. Best regards, Mirsad Todorovac >> --- >> v1: initial version. >> >> tools/testing/selftests/x86/syscall_numbering.c | 3 ++- >> 1 file changed, 2 insertions(+), 1 deletion(-) >> >> diff --git a/tools/testing/selftests/x86/syscall_numbering.c b/tools/testing/selftests/x86/syscall_numbering.c >> index 991591718bb0..41c42b7b54a6 100644 >> --- a/tools/testing/selftests/x86/syscall_numbering.c >> +++ b/tools/testing/selftests/x86/syscall_numbering.c >> @@ -25,6 +25,7 @@ >> #include <sys/mman.h> >> >> #include <linux/ptrace.h> >> +#include "../kselftest.h" >> >> /* Common system call numbers */ >> #define SYS_READ 0 >> @@ -313,7 +314,7 @@ static void test_syscall_numbering(void) >> * The MSB is supposed to be ignored, so we loop over a few >> * to test that out. >> */ >> - for (size_t i = 0; i < sizeof(msbs)/sizeof(msbs[0]); i++) { >> + for (size_t i = 0; i < ARRAY_SIZE(msbs); i++) { >> int msb = msbs[i]; >> run("Checking system calls with msb = %d (0x%x)\n", >> msb, msb); >