On Fri, Aug 24, 2012 at 10:33:37PM +0800, Wanpeng Li wrote: > From: Wanpeng Li <liwanp@xxxxxxxxxxxxxxxxxx> > > Rename get_allocated_memblock_reserved_regions_info() to > memblock_reserved_regions_info() so that the function name > looks more short and has prefix "memblock". > > Signed-off-by: Wanpeng Li <liwanp@xxxxxxxxxxxxxxxxxx> > --- > include/linux/memblock.h | 2 +- > mm/memblock.c | 2 +- > mm/nobootmem.c | 2 +- > 3 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/include/linux/memblock.h b/include/linux/memblock.h > index 569d67d..ab7b887 100644 > --- a/include/linux/memblock.h > +++ b/include/linux/memblock.h > @@ -50,7 +50,7 @@ phys_addr_t memblock_find_in_range_node(phys_addr_t start, phys_addr_t end, > phys_addr_t size, phys_addr_t align, int nid); > phys_addr_t memblock_find_in_range(phys_addr_t start, phys_addr_t end, > phys_addr_t size, phys_addr_t align); > -phys_addr_t get_allocated_memblock_reserved_regions_info(phys_addr_t *addr); > +phys_addr_t memblock_reserved_regions_info(phys_addr_t *addr); When you anyway change the prototype a description of what this function is supposed to be used for would be good. Many memblock function lacks this :-( Sam -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>