> -----Original Message----- > From: Chengming Zhou <chengming.zhou@xxxxxxxxx> > Sent: Friday, September 27, 2024 10:44 PM > To: Sridhar, Kanchana P <kanchana.p.sridhar@xxxxxxxxx>; linux- > kernel@xxxxxxxxxxxxxxx; linux-mm@xxxxxxxxx; hannes@xxxxxxxxxxx; > yosryahmed@xxxxxxxxxx; nphamcs@xxxxxxxxx; usamaarif642@xxxxxxxxx; > shakeel.butt@xxxxxxxxx; ryan.roberts@xxxxxxx; Huang, Ying > <ying.huang@xxxxxxxxx>; 21cnbao@xxxxxxxxx; akpm@xxxxxxxxxxxxxxxxxxxx > Cc: Zou, Nanhai <nanhai.zou@xxxxxxxxx>; Feghali, Wajdi K > <wajdi.k.feghali@xxxxxxxxx>; Gopal, Vinodh <vinodh.gopal@xxxxxxxxx> > Subject: Re: [PATCH v8 3/8] mm: zswap: Rename zswap_pool_get() to > zswap_pool_tryget(). > > On 2024/9/28 10:16, Kanchana P Sridhar wrote: > > Modify the name of the existing zswap_pool_get() to zswap_pool_tryget() > > to be representative of the call it makes to percpu_ref_tryget(). > > A subsequent patch will introduce a new zswap_pool_get() that calls > > percpu_ref_get(). > > > > The intent behind this change is for higher level zswap API such as > > zswap_store() to call zswap_pool_tryget() to check upfront if the pool's > > refcount is "0" (which means it could be getting destroyed) and to handle > > this as an error condition. zswap_store() would proceed only if > > zswap_pool_tryget() returns success, and any additional pool refcounts that > > need to be obtained for compressing sub-pages in a large folio could simply > > call zswap_pool_get(). > > > > Signed-off-by: Kanchana P Sridhar <kanchana.p.sridhar@xxxxxxxxx> > > Reviewed-by: Chengming Zhou <chengming.zhou@xxxxxxxxx> Thanks Chengming! Thanks, Kanchana > > > --- > > mm/zswap.c | 6 +++--- > > 1 file changed, 3 insertions(+), 3 deletions(-) > > > > diff --git a/mm/zswap.c b/mm/zswap.c > > index fd7a8c14457a..0f281e50a034 100644 > > --- a/mm/zswap.c > > +++ b/mm/zswap.c > > @@ -403,7 +403,7 @@ static void __zswap_pool_empty(struct percpu_ref > *ref) > > spin_unlock_bh(&zswap_pools_lock); > > } > > > > -static int __must_check zswap_pool_get(struct zswap_pool *pool) > > +static int __must_check zswap_pool_tryget(struct zswap_pool *pool) > > { > > if (!pool) > > return 0; > > @@ -441,7 +441,7 @@ static struct zswap_pool > *zswap_pool_current_get(void) > > rcu_read_lock(); > > > > pool = __zswap_pool_current(); > > - if (!zswap_pool_get(pool)) > > + if (!zswap_pool_tryget(pool)) > > pool = NULL; > > > > rcu_read_unlock(); > > @@ -462,7 +462,7 @@ static struct zswap_pool > *zswap_pool_find_get(char *type, char *compressor) > > if (strcmp(zpool_get_type(pool->zpool), type)) > > continue; > > /* if we can't get it, it's about to be destroyed */ > > - if (!zswap_pool_get(pool)) > > + if (!zswap_pool_tryget(pool)) > > continue; > > return pool; > > }