I see. I think adding
"pages" is better. Do I need to send a new email with a new patch? 发件人: David Hildenbrand <david@xxxxxxxxxx>
发送时间: 2024年9月27日 20:30:18 收件人: Xiang Gao; akpm@xxxxxxxxxxxxxxxxxxxx 抄送: linux-mm@xxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; 高翔 主题: [External Mail]Re: [PATCH] mm/cma: print total and used count in cma_alloc() [外部邮件] 此邮件来源于小米公司外部,请谨慎处理。若对邮件安全性存疑,请将邮件转发给misec@xxxxxxxxxx进行反馈
On 26.09.24 14:00, Xiang Gao wrote: > From: gaoxiang17 <gaoxiang17@xxxxxxxxxx> > > before: > [ 24.407814] cma: cma_alloc(cma (____ptrval____), name: reserved, count 1, align 0) > [ 24.413397] cma: cma_alloc(cma (____ptrval____), name: reserved, count 1, align 0) > [ 24.415886] cma: cma_alloc(cma (____ptrval____), name: reserved, count 1, align 0) > > after: > [ 24.097989] cma: cma_alloc(cma (____ptrval____), name: reserved, total count 16384, used count: 64, request count 1, align 0) > [ 24.104260] cma: cma_alloc(cma (____ptrval____), name: reserved, total count 16384, used count: 65, request count 1, align 0) > [ 24.107504] cma: cma_alloc(cma (____ptrval____), name: reserved, total count 16384, used count: 66, request count 1, align 0) > > Signed-off-by: gaoxiang17 <gaoxiang17@xxxxxxxxxx> > --- > mm/cma.c | 15 +++++++++++++-- > 1 file changed, 13 insertions(+), 2 deletions(-) > > diff --git a/mm/cma.c b/mm/cma.c > index 2d9fae939283..fc35a86aa82f 100644 > --- a/mm/cma.c > +++ b/mm/cma.c > @@ -403,6 +403,17 @@ static void cma_debug_show_areas(struct cma *cma) > spin_unlock_irq(&cma->lock); > } > > +static unsigned long cma_get_used(struct cma *cma) I would call it "cma_get_used_pages()" > +{ > + unsigned long used; > + > + spin_lock_irq(&cma->lock); > + used = bitmap_weight(cma->bitmap, (int)cma_bitmap_maxno(cma)); > + spin_unlock_irq(&cma->lock); > + > + return used << cma->order_per_bit; > +} > + > static struct page *__cma_alloc(struct cma *cma, unsigned long count, > unsigned int align, gfp_t gfp) > { > @@ -420,8 +431,8 @@ static struct page *__cma_alloc(struct cma *cma, unsigned long count, > if (!cma || !cma->count || !cma->bitmap) > return page; > > - pr_debug("%s(cma %p, name: %s, count %lu, align %d)\n", __func__, > - (void *)cma, cma->name, count, align); > + pr_debug("%s(cma %p, name: %s, total count %lu, used count: %lu, request count %lu, align %d)\n", __func__, I would suggest dropping the "count", or using "pages" instead. Also, inconsistent usage of ":". Either: pr_debug("%s(cma %p, name: %s, total: %lu, used: %lu, requested: %lu, ..." or pr_debug("%s(cma %p, name: %s, total pages: %lu, used pages: %lu, requested pages: %lu, ..." > + (void *)cma, cma->name, cma->count, cma_get_used(cma), count, align); > > if (!count) > return page; -- Cheers, David / dhildenb |