Re: [RFC PATCH] compiler.h: Introduce ptr_eq() to preserve address dependency

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2024-09-27 22:33, Mathieu Desnoyers wrote:
[...]

---
  include/linux/compiler.h | 62 ++++++++++++++++++++++++++++++++++++++++
  1 file changed, 62 insertions(+)


I'm wondering if this really belongs in compiler.h, or if it's so
RCU/HP specific that it should be implemented in rcupdate.h ?

[... ]
+static __always_inline
+int ptr_eq(const volatile void *a, const volatile void *b)

And perhaps rename this to rcu_ptr_eq() ?

Thanks,

Mathieu

+{
+	OPTIMIZER_HIDE_VAR(a);
+	OPTIMIZER_HIDE_VAR(b);
+	return a == b;
+}
+



--
Mathieu Desnoyers
EfficiOS Inc.
https://www.efficios.com





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux