Anyway, I wanted to get an RFC out to get some rough agreement on what the struct should look like, get some bikeshedding on the name done, and what else needs to be massaged as part of this. I think that cache_create() is the deepest we should stuff struct kmem_cache_args into the bowels of slab. Signed-off-by: Christian Brauner <brauner@xxxxxxxxxx> --- Christian Brauner (6): slab: introduce kmem_cache_setup() slab: port KMEM_CACHE() to kmem_cache_setup() slab: port KMEM_CACHE_USERCOPY() to kmem_cache_setup() file: port to kmem_cache_setup() slab: remove kmem_cache_create_rcu() io_uring: port to kmem_cache_setup() Documentation/core-api/memory-allocation.rst | 10 +- fs/file_table.c | 12 ++- include/linux/slab.h | 51 ++++++++--- io_uring/io_uring.c | 15 +-- mm/slab_common.c | 132 ++++++++++++--------------- 5 files changed, 121 insertions(+), 99 deletions(-) --- base-commit: 6e016babce7c845ed015da25c7a097fa3482d95a change-id: 20240902-work-kmem_cache_args-e9760972c7d4