On Thu, Aug 22, 2024 at 09:13:10AM +0200, Christophe Leroy wrote: > diff --git a/arch/x86/include/asm/pvclock.h b/arch/x86/include/asm/pvclock.h > index 0c92db84469d..6e4f8fae3ce9 100644 > --- a/arch/x86/include/asm/pvclock.h > +++ b/arch/x86/include/asm/pvclock.h > @@ -5,6 +5,7 @@ > #include <asm/clocksource.h> > #include <asm/pvclock-abi.h> > > +struct timespec64; > /* some helper functions for xen and kvm pv clock sources */ > u64 pvclock_clocksource_read(struct pvclock_vcpu_time_info *src); > u64 pvclock_clocksource_read_nowd(struct pvclock_vcpu_time_info *src); This change isn't mentioned in the commit message and could probably benefit from doing so. > diff --git a/lib/vdso/getrandom.c b/lib/vdso/getrandom.c > index b230f0b10832..cab153c5f9be 100644 > --- a/lib/vdso/getrandom.c > +++ b/lib/vdso/getrandom.c > @@ -3,15 +3,13 @@ > * Copyright (C) 2022-2024 Jason A. Donenfeld <Jason@xxxxxxxxx>. All Rights Reserved. > */ > > -#include <linux/cache.h> > -#include <linux/kernel.h> > -#include <linux/time64.h> > +#include <linux/minmax.h> > #include <vdso/datapage.h> > #include <vdso/getrandom.h> > +#include <vdso/unaligned.h> Ah, that's where you do it. Ignore my comment on the previous commit, then. > #include <asm/vdso/getrandom.h> > -#include <asm/vdso/vsyscall.h> > -#include <asm/unaligned.h> > #include <uapi/linux/mman.h> > +#include <uapi/linux/random.h> > > #define MEMCPY_AND_ZERO_SRC(type, dst, src, len) do { \ > while (len >= sizeof(type)) { \ > @@ -23,6 +21,9 @@ > } \ > } while (0) > > +#define _PAGE_SIZE (1UL << CONFIG_PAGE_SHIFT) > +#define _PAGE_MASK (~(_PAGE_SIZE - 1)) If PAGE_SIZE isn't defined at this point, why not just call it PAGE_SIZE instead of _PAGE_SIZE? But if that's the case, why not put the vdso definition of PAGE_SIZE into some vdso header included by this file?