Hi, Besides the obvious (and desired) difference between krealloc() and kvrealloc(), there is some inconsistency in their function signatures and behavior: - krealloc() frees the memory when the requested size is zero, whereas kvrealloc() simply returns a pointer to the existing allocation. - krealloc() behaves like kmalloc() if a NULL pointer is passed, whereas kvrealloc() does not accept a NULL pointer at all and, if passed, would fault instead. - krealloc() is self-contained, whereas kvrealloc() relies on the caller to provide the size of the previous allocation. Inconsistent behavior throughout allocation APIs is error prone, hence make kvrealloc() behave like krealloc(), which seems superior in all mentioned aspects. In order to be able to get rid of kvrealloc()'s oldsize parameter, introduce vrealloc() and make use of it in kvrealloc(). Making use of vrealloc() in kvrealloc() also provides oppertunities to grow (and shrink) allocations more efficiently. For instance, vrealloc() can be optimized to allocate and map additional pages to grow the allocation or unmap and free unused pages to shrink the allocation. Besides the above, those functions are required by Rust's allocator abstractons [1] (rework based on this series in [2]). With `Vec` or `KVec` respectively, potentially growing (and shrinking) data structures are rather common. The patches of this series can also be found in [3]. [1] https://lore.kernel.org/lkml/20240704170738.3621-1-dakr@xxxxxxxxxx/ [2] https://git.kernel.org/pub/scm/linux/kernel/git/dakr/linux.git/log/?h=rust/mm [3] https://git.kernel.org/pub/scm/linux/kernel/git/dakr/linux.git/log/?h=mm/krealloc Changes in v2: - remove unnecessary extern and move __realloc_size to a new line for vrealloc_noprof() and kvrealloc_noprof() - drop EXPORT_SYMBOL for vrealloc_noprof() - rename to_kmalloc_flags() to kmalloc_gfp_adjust() - fix missing NULL check in vrealloc_noprof() - rephrase TODO comments in vrealloc_noprof() Danilo Krummrich (2): mm: vmalloc: implement vrealloc() mm: kvmalloc: align kvrealloc() with krealloc() arch/arm64/kvm/nested.c | 1 - arch/powerpc/platforms/pseries/papr-vpd.c | 5 +- drivers/gpu/drm/drm_exec.c | 3 +- fs/xfs/xfs_log_recover.c | 2 +- include/linux/slab.h | 4 +- include/linux/vmalloc.h | 4 + kernel/resource.c | 3 +- lib/fortify_kunit.c | 3 +- mm/util.c | 89 +++++++++++++++-------- mm/vmalloc.c | 59 +++++++++++++++ 10 files changed, 129 insertions(+), 44 deletions(-) base-commit: 933069701c1b507825b514317d4edd5d3fd9d417 -- 2.45.2