On 7/10/24 01:28, Kees Cook wrote:
On Tue, Jul 09, 2024 at 11:02:55PM +0200, Marco Elver wrote:
On Tue, 9 Jul 2024 at 22:28, Kees Cook <kees@xxxxxxxxxx> wrote:
On Tue, Jul 09, 2024 at 10:26:32AM -0700, Christoph Lameter (Ampere) wrote:
On Mon, 8 Jul 2024, Kees Cook wrote:
obj = kmalloc(obj, gfp);
Could we avoid repeating "obj" in this pattern?
F.e.
KMALLOC(obj, gfp);
This appears to be the common feedback, which is good! :) And we can
still have it return "obj" as well, so it could still be used in
"return" statements, etc. I will work up a new RFC...
More macros like this only obfuscate the code further. The name would
become something that makes it really clear there's an assignment.
assign_kmalloc(obj, gfp)
There may be better options. Also ALLCAPS could be avoided here, as we
have done with other language-like features (vs. pure constants).
So, in looking a code patterns, it seems what we really want more than
returning the object that was allocated is actually returning the size
of the allocation size requested. i.e.:
info->size = struct_size(ptr, flex_member, count);
info->obj = kmalloc(info->size, gfp);
would become:
info->size = kmalloc(info->obj, flex_member, count, gfp);
-Kees
that will work out also for the (IMO) most common case of checking if
the allocation succeeded:
if (!kmalloc(my_foo, flex_part, count, gfp))
return -ENOMEM;