On 16.05.24 14:15, Alex Shi wrote:
On 4/30/24 8:57 PM, David Hildenbrand wrote:
@@ -2972,7 +2972,7 @@ int __ksm_enter(struct mm_struct *mm)
struct mm_slot *slot;
int needs_wakeup;
- ksm_slot = mm_slot_alloc(mm_slot_cache);
+ ksm_slot = mm_slot_alloc(ksm_slot_cache);
Similarly, this makes the code more confusion. The pattern in khugepaged is similarly:
mm_slot = mm_slot_alloc(mm_slot_cache);
Could we rename it to khg_mm_slot_cache in khugepaged?
I don't see any sense in such renaming, sorry. This code resides in
ksm.c/khugepaged.c respectively and at least for me is, therefore, quite
clear.
--
Cheers,
David / dhildenb