On Thu, Apr 11, 2024 at 07:00:36PM +0300, Mike Rapoport wrote: > From: "Mike Rapoport (IBM)" <rppt@xxxxxxxxxx> > > Hi, > > Since v3 I looked into making execmem more of an utility toolbox, as we > discussed at LPC with Mark Rutland, but it was getting more hairier than > having a struct describing architecture constraints and a type identifying > the consumer of execmem. > > And I do think that having the description of architecture constraints for > allocations of executable memory in a single place is better that having it > spread all over the place. > > The patches available via git: > https://git.kernel.org/pub/scm/linux/kernel/git/rppt/linux.git/log/?h=execmem/v4 > > v4 changes: > * rebase on v6.9-rc2 > * rename execmem_params to execmem_info and execmem_arch_params() to > execmem_arch_setup() > * use single execmem_alloc() API instead of execmem_{text,data}_alloc() (Song) > * avoid extra copy of execmem parameters (Rick) > * run execmem_init() as core_initcall() except for the architectures that > may allocated text really early (currently only x86) (Will) > * add acks for some of arm64 and riscv changes, thanks Will and Alexandre > * new commits: > - drop call to kasan_alloc_module_shadow() on arm64 because it's not > needed anymore > - rename MODULE_START to MODULES_VADDR on MIPS > - use CONFIG_EXECMEM instead of CONFIG_MODULES on powerpc as per Christophe: > https://lore.kernel.org/all/79062fa3-3402-47b3-8920-9231ad05e964@xxxxxxxxxx/ > > v3: https://lore.kernel.org/all/20230918072955.2507221-1-rppt@xxxxxxxxxx > * add type parameter to execmem allocation APIs > * remove BPF dependency on modules > > v2: https://lore.kernel.org/all/20230616085038.4121892-1-rppt@xxxxxxxxxx > * Separate "module" and "others" allocations with execmem_text_alloc() > and jit_text_alloc() > * Drop ROX entailment on x86 > * Add ack for nios2 changes, thanks Dinh Nguyen > > v1: https://lore.kernel.org/all/20230601101257.530867-1-rppt@xxxxxxxxxx > > = Cover letter from v1 (sligtly updated) = > > module_alloc() is used everywhere as a mean to allocate memory for code. > > Beside being semantically wrong, this unnecessarily ties all subsystmes > that need to allocate code, such as ftrace, kprobes and BPF to modules and > puts the burden of code allocation to the modules code. > > Several architectures override module_alloc() because of various > constraints where the executable memory can be located and this causes > additional obstacles for improvements of code allocation. > > A centralized infrastructure for code allocation allows allocations of > executable memory as ROX, and future optimizations such as caching large > pages for better iTLB performance and providing sub-page allocations for > users that only need small jit code snippets. > > Rick Edgecombe proposed perm_alloc extension to vmalloc [1] and Song Liu > proposed execmem_alloc [2], but both these approaches were targeting BPF > allocations and lacked the ground work to abstract executable allocations > and split them from the modules core. > > Thomas Gleixner suggested to express module allocation restrictions and > requirements as struct mod_alloc_type_params [3] that would define ranges, > protections and other parameters for different types of allocations used by > modules and following that suggestion Song separated allocations of > different types in modules (commit ac3b43283923 ("module: replace > module_layout with module_memory")) and posted "Type aware module > allocator" set [4]. > > I liked the idea of parametrising code allocation requirements as a > structure, but I believe the original proposal and Song's module allocator > was too module centric, so I came up with these patches. > > This set splits code allocation from modules by introducing execmem_alloc() > and and execmem_free(), APIs, replaces call sites of module_alloc() and > module_memfree() with the new APIs and implements core text and related > allocations in a central place. > > Instead of architecture specific overrides for module_alloc(), the > architectures that require non-default behaviour for text allocation must > fill execmem_info structure and implement execmem_arch_setup() that returns > a pointer to that structure. If an architecture does not implement > execmem_arch_setup(), the defaults compatible with the current > modules::module_alloc() are used. > > Since architectures define different restrictions on placement, > permissions, alignment and other parameters for memory that can be used by > different subsystems that allocate executable memory, execmem APIs > take a type argument, that will be used to identify the calling subsystem > and to allow architectures to define parameters for ranges suitable for that > subsystem. > > The new infrastructure allows decoupling of BPF, kprobes and ftrace from > modules, and most importantly it paves the way for ROX allocations for > executable memory. It looks like you're just doing API cleanup first, then improving the implementation later? Patch set looks nice and clean; previous versions did seem to leak too much arch/module details (or perhaps we were just bikeshedding too much ;) - but the API first approach is nice. Looking forward to seeing this merged.