Hi Stafford, On Wed, Apr 10, 2024 at 10:52 PM Stafford Horne <shorne@xxxxxxxxx> wrote: > This patch adds the relocations. Note, we use the old naming R_OR32_* > instead or the new naming R_OR1K_* to avoid change as this header is > exported as a user api. > --- a/arch/openrisc/include/uapi/asm/elf.h > +++ b/arch/openrisc/include/uapi/asm/elf.h > @@ -43,6 +43,8 @@ > #define R_OR32_JUMPTARG 6 > #define R_OR32_VTINHERIT 7 > #define R_OR32_VTENTRY 8 > +#define R_OR32_AHI16 35 > +#define R_OR32_SLO16 39 Would it make sense to switch to the new names, e.g. #define R_OR1K_NONE 0 and add definitions for backwards compatibility? #define R_OR32_NONE R_OR1K_NONE Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds