From: Xiongwei Song <xiongwei.song@xxxxxxxxxxxxx> This series is to remove the unnecessary check for filling cpu partial and improve the readability. Introduce slub_get_cpu_partial() and dummy function to remove #ifdef of CONFIG_SLUB_CPU_PARTIAL. Please check patch 2 and patch 3. Also add the comparison in patch 3 for when breaking from filling cpu partial loop with ">" or ">=". For more details, please check the patch 3 inside. No functionality changed. Changes in v2: - Refine the commit message(from Vlastimil Babka's comments). - Refine the check conditions of filling cpu partial(as Vlastimil Babka suggested). - drop patch 4 of v1. v1: - https://lore.kernel.org/lkml/20240331021926.2732572-4-xiongwei.song@xxxxxxxxxxxxx/T/ Before v1: - Actually, the series is the improvement of patch below: https://lore.kernel.org/lkml/934f65c6-4d97-6c4d-b123-4937ede24a99@xxxxxxxxxx/T/ Regards, Xiongwei Xiongwei Song (3): mm/slub: remove the check of !kmem_cache_has_cpu_partial() mm/slub: add slub_get_cpu_partial() helper mm/slub: simplify get_partial_node() mm/slub.c | 20 +++++++++++++------- 1 file changed, 13 insertions(+), 7 deletions(-) -- 2.34.1