Hi Jonathan, Thank you for your feedback. I will fix them (inlined) in the next V11. On Wed, Apr 3, 2024 at 10:04 AM Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx> wrote: > > A few minor comments inline. > > > diff --git a/include/linux/memory-tiers.h b/include/linux/memory-tiers.h > > index a44c03c2ba3a..16769552a338 100644 > > --- a/include/linux/memory-tiers.h > > +++ b/include/linux/memory-tiers.h > > @@ -140,12 +140,13 @@ static inline int mt_perf_to_adistance(struct access_coordinate *perf, int *adis > > return -EIO; > > } > > > > -struct memory_dev_type *mt_find_alloc_memory_type(int adist, struct list_head *memory_types) > > +static inline struct memory_dev_type *mt_find_alloc_memory_type(int adist, > > + struct list_head *memory_types) > > { > > return NULL; > > } > > > > -void mt_put_memory_types(struct list_head *memory_types) > > +static inline void mt_put_memory_types(struct list_head *memory_types) > > { > Why in this patch and not previous one? I've also noticed this issue. I will fix it in the next V11. > > > > } > > diff --git a/mm/memory-tiers.c b/mm/memory-tiers.c > > index 974af10cfdd8..44fa10980d37 100644 > > --- a/mm/memory-tiers.c > > +++ b/mm/memory-tiers.c > > @@ -36,6 +36,11 @@ struct node_memory_type_map { > > > > static DEFINE_MUTEX(memory_tier_lock); > > static LIST_HEAD(memory_tiers); > > +/* > > + * The list is used to store all memory types that are not created > > + * by a device driver. > > + */ > > +static LIST_HEAD(default_memory_types); > > static struct node_memory_type_map node_memory_types[MAX_NUMNODES]; > > struct memory_dev_type *default_dram_type; > > > > @@ -108,6 +113,8 @@ static struct demotion_nodes *node_demotion __read_mostly; > > > > static BLOCKING_NOTIFIER_HEAD(mt_adistance_algorithms); > > > > +/* The lock is used to protect `default_dram_perf*` info and nid. */ > > +static DEFINE_MUTEX(default_dram_perf_lock); > > static bool default_dram_perf_error; > > static struct access_coordinate default_dram_perf; > > static int default_dram_perf_ref_nid = NUMA_NO_NODE; > > @@ -505,7 +512,8 @@ static inline void __init_node_memory_type(int node, struct memory_dev_type *mem > > static struct memory_tier *set_node_memory_tier(int node) > > { > > struct memory_tier *memtier; > > - struct memory_dev_type *memtype; > > + struct memory_dev_type *mtype = default_dram_type; > > Does the rename add anything major to the patch? > If not I'd leave it alone to reduce the churn and give > a more readable patch. If it is worth doing perhaps > a precursor patch? > Either name works. Keeping it the same name will make the code easier to follow. I agree! Thanks. > > + int adist = MEMTIER_ADISTANCE_DRAM; > > pg_data_t *pgdat = NODE_DATA(node); > > > > > > @@ -514,11 +522,20 @@ static struct memory_tier *set_node_memory_tier(int node) > > if (!node_state(node, N_MEMORY)) > > return ERR_PTR(-EINVAL); > > > > - __init_node_memory_type(node, default_dram_type); > > + mt_calc_adistance(node, &adist); > > + if (node_memory_types[node].memtype == NULL) { > > + mtype = mt_find_alloc_memory_type(adist, &default_memory_types); > > + if (IS_ERR(mtype)) { > > + mtype = default_dram_type; > > + pr_info("Failed to allocate a memory type. Fall back.\n"); > > + } > > + } > > + > > + __init_node_memory_type(node, mtype); > > > > - memtype = node_memory_types[node].memtype; > > - node_set(node, memtype->nodes); > > - memtier = find_create_memory_tier(memtype); > > + mtype = node_memory_types[node].memtype; > > + node_set(node, mtype->nodes); > > + memtier = find_create_memory_tier(mtype); > > if (!IS_ERR(memtier)) > > rcu_assign_pointer(pgdat->memtier, memtier); > > return memtier; > > @@ -655,6 +672,33 @@ void mt_put_memory_types(struct list_head *memory_types) > > } > > EXPORT_SYMBOL_GPL(mt_put_memory_types); > > > > +/* > > + * This is invoked via `late_initcall()` to initialize memory tiers for > > + * CPU-less memory nodes after driver initialization, which is > > + * expected to provide `adistance` algorithms. > > + */ > > +static int __init memory_tier_late_init(void) > > +{ > > + int nid; > > + > > + mutex_lock(&memory_tier_lock); > > + for_each_node_state(nid, N_MEMORY) > > + if (node_memory_types[nid].memtype == NULL) > > + /* > > + * Some device drivers may have initialized memory tiers > > + * between `memory_tier_init()` and `memory_tier_late_init()`, > > + * potentially bringing online memory nodes and > > + * configuring memory tiers. Exclude them here. > > + */ > > Does the comment refer to this path, or to ones where memtype is set? > Yes, the comment is for explaining why the if condition is used. > > + set_node_memory_tier(nid); > > Given the large comment I would add {} to help with readability. > You could flip the logic to reduce indent > for_each_node_state(nid, N_MEMORY) { > if (node_memory_types[nid].memtype) > continue; > /* > * Some device drivers may have initialized memory tiers > * between `memory_tier_init()` and `memory_tier_late_init()`, > * potentially bringing online memory nodes and > * configuring memory tiers. Exclude them here. > */ > set_node_memory_tier(nid); > > I will change it accordingly. > > + > > + establish_demotion_targets(); > > + mutex_unlock(&memory_tier_lock); > > + > > + return 0; > > +} > > +late_initcall(memory_tier_late_init); > > + > > static void dump_hmem_attrs(struct access_coordinate *coord, const char *prefix) > > { > > pr_info( > > @@ -668,7 +712,7 @@ int mt_set_default_dram_perf(int nid, struct access_coordinate *perf, > > { > > int rc = 0; > > > > - mutex_lock(&memory_tier_lock); > > + mutex_lock(&default_dram_perf_lock); > > As below, this is a classic case where guard() will help readability. > I will change it accordingly. > > if (default_dram_perf_error) { > > rc = -EIO; > > goto out; > > @@ -716,23 +760,30 @@ int mt_set_default_dram_perf(int nid, struct access_coordinate *perf, > > } > > > > out: > > - mutex_unlock(&memory_tier_lock); > > + mutex_unlock(&default_dram_perf_lock); > > return rc; > > } > > > > int mt_perf_to_adistance(struct access_coordinate *perf, int *adist) > > { > > - if (default_dram_perf_error) > > - return -EIO; > > + int rc = 0; > > Looks like rc is set in all paths that reach where it issued. > Using guard(mutex), I will no longer need `int rc`. Replace `rc =` with `return XXX`. > > > > - if (default_dram_perf_ref_nid == NUMA_NO_NODE) > > - return -ENOENT; > > + mutex_lock(&default_dram_perf_lock); > > This would benefit quite a lot from > guard(mutex)(&default_dram_perf_lock); > and direct returns throughout. > Got it. I will change it accordingly. > > > + if (default_dram_perf_error) { > > + rc = -EIO; > > + goto out; > > + } > > > > if (perf->read_latency + perf->write_latency == 0 || > > - perf->read_bandwidth + perf->write_bandwidth == 0) > > - return -EINVAL; > > + perf->read_bandwidth + perf->write_bandwidth == 0) { > > + rc = -EINVAL; > > + goto out; > > + } > > > > - mutex_lock(&memory_tier_lock); > > + if (default_dram_perf_ref_nid == NUMA_NO_NODE) { > > + rc = -ENOENT; > > + goto out; > > + } > > /* > > * The abstract distance of a memory node is in direct proportion to > > * its memory latency (read + write) and inversely proportional to its > > @@ -745,9 +796,10 @@ int mt_perf_to_adistance(struct access_coordinate *perf, int *adist) > > (default_dram_perf.read_latency + default_dram_perf.write_latency) * > > (default_dram_perf.read_bandwidth + default_dram_perf.write_bandwidth) / > > (perf->read_bandwidth + perf->write_bandwidth); > > - mutex_unlock(&memory_tier_lock); > > > > - return 0; > > +out: > > + mutex_unlock(&default_dram_perf_lock); > > + return rc; > > } > > EXPORT_SYMBOL_GPL(mt_perf_to_adistance); > > > > @@ -858,7 +910,8 @@ static int __init memory_tier_init(void) > > * For now we can have 4 faster memory tiers with smaller adistance > > * than default DRAM tier. > > */ > > - default_dram_type = alloc_memory_type(MEMTIER_ADISTANCE_DRAM); > > + default_dram_type = mt_find_alloc_memory_type(MEMTIER_ADISTANCE_DRAM, > > + &default_memory_types); > > Unusual indenting. Align with just after ( > Aligning with "(" will exceed 100 columns. Would that be acceptable? > > if (IS_ERR(default_dram_type)) > > panic("%s() failed to allocate default DRAM tier\n", __func__); > > > > @@ -868,6 +921,14 @@ static int __init memory_tier_init(void) > > * types assigned. > > */ > > for_each_node_state(node, N_MEMORY) { > > + if (!node_state(node, N_CPU)) > > + /* > > + * Defer memory tier initialization on CPUless numa nodes. > > + * These will be initialized after firmware and devices are > > I think this wraps at just over 80 chars. Seems silly to wrap so tightly and not > quite fit under 80. (this is about 83 chars. > I can fix this. I have a question. From my patch, this is <80 chars. However, in an email, this is >80 chars. Does that mean we need to count the number of chars in an email, not in a patch? Or if I missed something? like vim configuration or? > > + * initialized. > > + */ > > + continue; > > + > > memtier = set_node_memory_tier(node); > > if (IS_ERR(memtier)) > > /* > -- Best regards, Ho-Ren (Jack) Chuang 莊賀任