This patchset converts the hugetlb fault path to use struct vm_fault. This helps make the code more readable, and alleviates the stack by allowing us to consolidate many fault-related variables into an individual pointer. ---- v2: - renamed patchset from 'Define struct vm_fault in handle_mm_fault()' - Dropped patches 4/5 - These allowed vmf->{address,pgoff} to be modified, but that allows misuse of these fields. Converting hugetlb to using the same address/pgoff as generic mm is not simple, so that can be done later. Vishal Moola (Oracle) (3): hugetlb: Convert hugetlb_fault() to use struct vm_fault hugetlb: Convert hugetlb_no_page() to use struct vm_fault hugetlb: Convert hugetlb_wp() to use struct vm_fault mm/hugetlb.c | 194 +++++++++++++++++++++++++-------------------------- 1 file changed, 95 insertions(+), 99 deletions(-) -- 2.43.0