The current vma_address() pretends that the ambiguity between head & tail page is an advantage. If you pass a head page to vma_address(), it will operate on all pages in the folio, while if you pass a tail page, it will operate on a single page. That's not what any of the callers actually want, so first convert all callers to use vma_pgoff_address() and then rename vma_pgoff_address() to vma_address(). Matthew Wilcox (Oracle) (3): mm: Correct page_mapped_in_vma() for large folios mm: Remove vma_address() mm: Rename vma_pgoff_address back to vma_address mm/internal.h | 28 ++++++++++------------------ mm/memory-failure.c | 2 +- mm/page_vma_mapped.c | 4 +++- mm/rmap.c | 14 ++++++++++---- 4 files changed, 24 insertions(+), 24 deletions(-) -- 2.43.0