Hi Matthew, On 26/03/2024 17:10, Matthew Wilcox (Oracle) wrote: > All implementations that aren't no-ops just set a bit in the flags, > and we want to use the folio flags rather than the page flags for that. > Rename it to arch_clear_hugetlb_flags() while we're touching it so nobody > thinks it's used for THP. > [...] > diff --git a/include/linux/hugetlb.h b/include/linux/hugetlb.h > index d748628efc5e..cc420c42a773 100644 > --- a/include/linux/hugetlb.h > +++ b/include/linux/hugetlb.h > @@ -837,8 +837,8 @@ static inline int is_hugepage_only_range(struct mm_struct *mm, > #endif > > #ifndef arch_clear_hugepage_flags You need to update this line to the new name. Currently failing to build on arm64 since it now defines the new arch_clear_hugetlb_flags. > -static inline void arch_clear_hugepage_flags(struct page *page) { } > -#define arch_clear_hugepage_flags arch_clear_hugepage_flags > +static inline void arch_clear_hugetlb_flags(struct folio *folio) { } > +#define arch_clear_hugetlb_flags arch_clear_hugetlb_flags > #endif Thanks, Ryan