On Mon, Mar 11, 2024 at 10:37 PM David Hildenbrand <david@xxxxxxxxxx> wrote: > > On 21.02.24 22:08, Barry Song wrote: > > From: Barry Song <v-songbaohua@xxxxxxxx> > > > > The code is quite hard to read, we are still writing swap_map after > > errors happen. Though the written value is as before, > > > > has_cache = count & SWAP_HAS_CACHE; > > count &= ~SWAP_HAS_CACHE; > > [snipped] > > WRITE_ONCE(p->swap_map[offset], count | has_cache); > > > > It would be better to entirely drop the WRITE_ONCE for both > > performance and readability. > > > > Signed-off-by: Barry Song <v-songbaohua@xxxxxxxx> > > --- > > -v2: drop goto according to Andrew, Thanks! > > > > mm/swapfile.c | 3 ++- > > 1 file changed, 2 insertions(+), 1 deletion(-) > > > > diff --git a/mm/swapfile.c b/mm/swapfile.c > > index 556ff7347d5f..7cb6d9a2d51d 100644 > > --- a/mm/swapfile.c > > +++ b/mm/swapfile.c > > @@ -3320,7 +3320,8 @@ static int __swap_duplicate(swp_entry_t entry, unsigned char usage) > > } else > > err = -ENOENT; /* unused swap entry */ > > > > - WRITE_ONCE(p->swap_map[offset], count | has_cache); > > + if (!err) > > + WRITE_ONCE(p->swap_map[offset], count | has_cache); > > > > unlock_out: > > unlock_cluster_or_swap_info(p, ci); > > Maybe too late, but LGTM > > Reviewed-by: David Hildenbrand <david@xxxxxxxxxx> David, thanks! Though it is probably too late as this one has been in mm-stable for a long time. > > -- > Cheers, > > David / dhildenb Thanks Barry