On Tue, Feb 13, 2024 at 11:31 AM Suren Baghdasaryan <surenb@xxxxxxxxxx> wrote: > > On Tue, Feb 13, 2024 at 11:27 AM Liam R. Howlett > <Liam.Howlett@xxxxxxxxxx> wrote: > > > > * Lokesh Gidra <lokeshgidra@xxxxxxxxxx> [240213 14:18]: > > ... > > > > > > > We could use something like uffd_prepare(), uffd_complete() but I > > > > > thought of those names rather late in the cycle, but I've already caused > > > > > many iterations of this patch set and that clean up didn't seem as vital > > > > > as simplicity and clarity of the locking code. > > > > > > I anyway have to send another version to fix the error handling that > > > you reported earlier. I can take care of this in that version. > > > > > > mfill_atomic...() functions (annoyingly) have to sometimes unlock and > > > relock. Using prepare/complete in that context seems incompatible. > > > > > > > > > > > Maybe lock_vma_for_uffd()/unlock_vma_for_uffd()? Whatever name is > > > > better I'm fine with it but all these #ifdef's sprinkled around don't > > > > contribute to the readability. > > > > > > I'll wait for an agreement on this because I too don't like using so > > > many ifdef's either. > > > > > > Since these functions are supposed to have prototype depending on > > > mfill/move, how about the following names: > > > > > > uffd_lock_mfill_vma()/uffd_unlock_mfill_vma() > > > uffd_lock_move_vmas()/uffd_unlock_move_vmas() > > > > > > Of course, I'm open to other suggestions as well. > > > > > > > I'm happy with those if you remove the vma/vmas from the name. > > Sounds good to me. > Sure. I'll do that: Asking to avoid any more iterations: these functions should call the currently defined ones or should replace them. For instance, should I do the following: #ifdef CONFIG_PER_VMA_LOCK ... uffd_mfill_lock() { return find_and_lock_dst_vma(...); } #else ...uffd_mfill_lock() { return lock_mm_and_find_dst_vma(...); } #endif or have the function replace find_and_lock_dst_vma()/lock_mm_and_find_dst_vma() ? > > > > -- > > To unsubscribe from this group and stop receiving emails from it, send an email to kernel-team+unsubscribe@xxxxxxxxxxx. > >