On Mon, Jan 22, 2024 at 04:27:08PM -0800, Kees Cook wrote: > In an effort to separate intentional arithmetic wrap-around from > unexpected wrap-around, we need to refactor places that depend on this > kind of math. One of the most common code patterns of this is: > > VAR + value < VAR > > Notably, this is considered "undefined behavior" for signed and pointer > types, which the kernel works around by using the -fno-strict-overflow > option in the build[1] (which used to just be -fwrapv). Regardless, we > want to get the kernel source to the position where we can meaningfully > instrument arithmetic wrap-around conditions and catch them when they > are unexpected, regardless of whether they are signed[2], unsigned[3], > or pointer[4] types. > > Refactor open-coded unsigned wrap-around addition test to use > check_add_overflow(), retaining the result for later usage (which removes > the redundant open-coded addition). This paves the way to enabling the > unsigned wrap-around sanitizer[2] in the future. > > Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1] > Link: https://github.com/KSPP/linux/issues/26 [2] > Link: https://github.com/KSPP/linux/issues/27 [3] > Link: https://github.com/KSPP/linux/issues/344 [4] > Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> > Cc: Uladzislau Rezki <urezki@xxxxxxxxx> > Cc: Christoph Hellwig <hch@xxxxxxxxxxxxx> > Cc: Lorenzo Stoakes <lstoakes@xxxxxxxxx> > Cc: linux-mm@xxxxxxxxx > Signed-off-by: Kees Cook <keescook@xxxxxxxxxxxx> > --- > mm/vmalloc.c | 5 +++-- > 1 file changed, 3 insertions(+), 2 deletions(-) > > diff --git a/mm/vmalloc.c b/mm/vmalloc.c > index d12a17fc0c17..7932ac99e9d3 100644 > --- a/mm/vmalloc.c > +++ b/mm/vmalloc.c > @@ -1223,6 +1223,7 @@ is_within_this_va(struct vmap_area *va, unsigned long size, > unsigned long align, unsigned long vstart) > { > unsigned long nva_start_addr; > + unsigned long sum; > > if (va->va_start > vstart) > nva_start_addr = ALIGN(va->va_start, align); > @@ -1230,11 +1231,11 @@ is_within_this_va(struct vmap_area *va, unsigned long size, > nva_start_addr = ALIGN(vstart, align); > > /* Can be overflowed due to big size or alignment. */ > - if (nva_start_addr + size < nva_start_addr || > + if (check_add_overflow(nva_start_addr, size, &sum) || > nva_start_addr < vstart) > return false; > > - return (nva_start_addr + size <= va->va_end); > + return (sum <= va->va_end); > } > > /* > -- > 2.34.1 > Looks good to me, Reviewed-by: Lorenzo Stoakes <lstoakes@xxxxxxxxx>