Re: [PATCH 06/20] mm: zswap: rename __zswap_load() to zswap_decompress()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Jan 29, 2024 at 5:42 PM Johannes Weiner <hannes@xxxxxxxxxxx> wrote:
>
> Signed-off-by: Johannes Weiner <hannes@xxxxxxxxxxx>
> ---
>  mm/zswap.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/mm/zswap.c b/mm/zswap.c
> index 7a7e8da2b4f8..bdc9f82fe4b9 100644
> --- a/mm/zswap.c
> +++ b/mm/zswap.c
> @@ -1316,7 +1316,7 @@ static int zswap_enabled_param_set(const char *val,
>         return ret;
>  }
>
> -static void __zswap_load(struct zswap_entry *entry, struct page *page)
> +static void zswap_decompress(struct zswap_entry *entry, struct page *page)

This is a much better name. Was gonna point this out in the original
series - it's clearly just decompression :)
Reviewed-by: Nhat Pham <nphamcs@xxxxxxxxx>

>  {
>         struct zpool *zpool = zswap_find_zpool(entry);
>         struct scatterlist input, output;
> @@ -1411,7 +1411,7 @@ static int zswap_writeback_entry(struct zswap_entry *entry,
>         zswap_entry_get(entry);
>         spin_unlock(&tree->lock);
>
> -       __zswap_load(entry, &folio->page);
> +       zswap_decompress(entry, &folio->page);
>
>         count_vm_event(ZSWPWB);
>         if (entry->objcg)
> @@ -1702,7 +1702,7 @@ bool zswap_load(struct folio *folio)
>         spin_unlock(&tree->lock);
>
>         if (entry->length)
> -               __zswap_load(entry, page);
> +               zswap_decompress(entry, page);
>         else {
>                 dst = kmap_local_page(page);
>                 zswap_fill_page(dst, entry->value);
> --
> 2.43.0
>





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux