On Tue, Jan 30, 2024 at 08:31:22AM -0800, Nhat Pham wrote: > On Mon, Jan 29, 2024 at 11:51 PM Yosry Ahmed <yosryahmed@xxxxxxxxxx> wrote: > > > > On Mon, Jan 29, 2024 at 08:36:41PM -0500, Johannes Weiner wrote: > > > Remove stale comment and unnecessary local variable. > > > > > > Signed-off-by: Johannes Weiner <hannes@xxxxxxxxxxx> > > > --- > > > mm/zswap.c | 10 +++------- > > > 1 file changed, 3 insertions(+), 7 deletions(-) > > > > > > diff --git a/mm/zswap.c b/mm/zswap.c > > > index 0c6adaf2fdb6..7a7e8da2b4f8 100644 > > > --- a/mm/zswap.c > > > +++ b/mm/zswap.c > > > @@ -546,15 +546,11 @@ static void zswap_entry_get(struct zswap_entry *entry) > > > entry->refcount++; > > > } > > > > > > -/* caller must hold the tree lock > > > -* remove from the tree and free it, if nobody reference the entry > > > -*/ > > > +/* caller must hold the tree lock */ > > > > We should replace all those "caller must hold the tree lock" comments > > with lockdep_assert_held() or assert_spin_locked() or something. > > > > I can send follow up patches on top if you don't want to resend this > > series. > > Agree. There's also this: > > /* should be called under RCU */ > #ifdef CONFIG_MEMCG > static inline struct mem_cgroup *mem_cgroup_from_entry(struct > zswap_entry *entry) > { > return entry->objcg ? obj_cgroup_memcg(entry->objcg) : NULL; > } > > which you pointed out in the per-cgroup zswap LRU review :) I will send out a patch this week or so.