On Tue, Jan 23, 2024 at 1:29 AM Kees Cook <keescook@xxxxxxxxxxxx> wrote: > > In an effort to separate intentional arithmetic wrap-around from > unexpected wrap-around, we need to refactor places that depend on this > kind of math. One of the most common code patterns of this is: > > VAR + value < VAR > > Notably, this is considered "undefined behavior" for signed and pointer > types, which the kernel works around by using the -fno-strict-overflow > option in the build[1] (which used to just be -fwrapv). Regardless, we > want to get the kernel source to the position where we can meaningfully > instrument arithmetic wrap-around conditions and catch them when they > are unexpected, regardless of whether they are signed[2], unsigned[3], > or pointer[4] types. > > Refactor open-coded wrap-around addition test to use add_would_overflow(). > This paves the way to enabling the wrap-around sanitizers in the future. > > Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1] > Link: https://github.com/KSPP/linux/issues/26 [2] > Link: https://github.com/KSPP/linux/issues/27 [3] > Link: https://github.com/KSPP/linux/issues/344 [4] > Cc: Andrey Ryabinin <ryabinin.a.a@xxxxxxxxx> > Cc: Alexander Potapenko <glider@xxxxxxxxxx> > Cc: Andrey Konovalov <andreyknvl@xxxxxxxxx> > Cc: Dmitry Vyukov <dvyukov@xxxxxxxxxx> > Cc: Vincenzo Frascino <vincenzo.frascino@xxxxxxx> > Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> > Cc: kasan-dev@xxxxxxxxxxxxxxxx > Cc: linux-mm@xxxxxxxxx > Signed-off-by: Kees Cook <keescook@xxxxxxxxxxxx> > --- > mm/kasan/generic.c | 2 +- > mm/kasan/sw_tags.c | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/mm/kasan/generic.c b/mm/kasan/generic.c > index df6627f62402..f9bc29ae09bd 100644 > --- a/mm/kasan/generic.c > +++ b/mm/kasan/generic.c > @@ -171,7 +171,7 @@ static __always_inline bool check_region_inline(const void *addr, > if (unlikely(size == 0)) > return true; > > - if (unlikely(addr + size < addr)) > + if (unlikely(add_would_overflow(addr, size))) > return !kasan_report(addr, size, write, ret_ip); > > if (unlikely(!addr_has_metadata(addr))) > diff --git a/mm/kasan/sw_tags.c b/mm/kasan/sw_tags.c > index 220b5d4c6876..79a3bbd66c32 100644 > --- a/mm/kasan/sw_tags.c > +++ b/mm/kasan/sw_tags.c > @@ -80,7 +80,7 @@ bool kasan_check_range(const void *addr, size_t size, bool write, > if (unlikely(size == 0)) > return true; > > - if (unlikely(addr + size < addr)) > + if (unlikely(add_would_overflow(addr, size))) > return !kasan_report(addr, size, write, ret_ip); > > tag = get_tag((const void *)addr); > -- > 2.34.1 > Acked-by: Andrey Konovalov <andreyknvl@xxxxxxxxx> Thanks!