[PATCH 0/2] mm: zswap: simplify zswap_swapoff()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This mini-series simplifies aims to zswap_swapoff(), which should
simplify in progress work touching it (zswap tree split, rbtree to
xarray conversion).

Patch 1 is a code readability change in the core swap code that makes
patch 2 (the actual simplification) more obviously correct.

Yosry Ahmed (2):
  mm: swap: update inuse_pages after all cleanups are done
  mm: zswap: remove unnecessary tree cleanups in zswap_swapoff()

 mm/swapfile.c | 4 ++--
 mm/zswap.c    | 9 ++-------
 2 files changed, 4 insertions(+), 9 deletions(-)

-- 
2.43.0.429.g432eaa2c6b-goog





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux