On Mon, Dec 11, 2023 at 8:47 PM Liang Chen <liangchen.linux@xxxxxxxxx> wrote: > > Wrap code for checking if a page is a page_pool page into a > function for better readability and ease of reuse. > > Signed-off-by: Liang Chen <liangchen.linux@xxxxxxxxx> > Reviewed-by: Yunsheng Lin <linyunsheng@xxxxxxxxxx> > Reviewed-by: Ilias Apalodimas <ilias.apalodimas@xxxxxxxxxx> Only 1 nit, feel free to ignore since especially if Jakub wants to merge the patch asap. Reviewed-by: Mina Almasry <almasrymina@xxxxxxxxxx> > --- > net/core/skbuff.c | 7 ++++++- > 1 file changed, 6 insertions(+), 1 deletion(-) > > diff --git a/net/core/skbuff.c b/net/core/skbuff.c > index b157efea5dea..7e26b56cda38 100644 > --- a/net/core/skbuff.c > +++ b/net/core/skbuff.c > @@ -890,6 +890,11 @@ static void skb_clone_fraglist(struct sk_buff *skb) > skb_get(list); > } > > +static bool is_pp_page(struct page *page) > +{ > + return (page->pp_magic & ~0x3UL) == PP_SIGNATURE; > +} > + > #if IS_ENABLED(CONFIG_PAGE_POOL) > bool napi_pp_put_page(struct page *page, bool napi_safe) > { > @@ -905,7 +910,7 @@ bool napi_pp_put_page(struct page *page, bool napi_safe) > * and page_is_pfmemalloc() is checked in __page_pool_put_page() > * to avoid recycling the pfmemalloc page. > */ > - if (unlikely((page->pp_magic & ~0x3UL) != PP_SIGNATURE)) > + if (unlikely(!is_pp_page(page))) Nit: I think the unlikely here is unnecessary anyway, and can be removed (if without else is already unlikely). > return false; > > pp = page->pp; > -- > 2.31.1 > > -- Thanks, Mina