Re: [PATCH] memblock: Return NUMA_NO_NODE instead of -1 to improve code readability

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Dec 07, 2023 at 09:10:01PM +0800, Yuntao Wang wrote:
> When no corresponding memory region is found for the given pfn, return
> NUMA_NO_NODE instead of -1. This improves code readability and aligns with
> the existing logic of the memblock_search_pfn_nid() function's user.
> 
> Signed-off-by: Yuntao Wang <ytcoode@xxxxxxxxx>

Applied, thanks!

> ---
>  mm/memblock.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/mm/memblock.c b/mm/memblock.c
> index 5a88d6d24d79..c1f579c23396 100644
> --- a/mm/memblock.c
> +++ b/mm/memblock.c
> @@ -1851,7 +1851,7 @@ int __init_memblock memblock_search_pfn_nid(unsigned long pfn,
>  	int mid = memblock_search(type, PFN_PHYS(pfn));
>  
>  	if (mid == -1)
> -		return -1;
> +		return NUMA_NO_NODE;
>  
>  	*start_pfn = PFN_DOWN(type->regions[mid].base);
>  	*end_pfn = PFN_DOWN(type->regions[mid].base + type->regions[mid].size);
> -- 
> 2.43.0
> 

-- 
Sincerely yours,
Mike.




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux