Acked-by: Chris Li <chrisl@xxxxxxxxxx> (Google) Chris On Tue, Dec 5, 2023 at 11:33 AM Nhat Pham <nphamcs@xxxxxxxxx> wrote: > > Rename ZSWP_WB to ZSWPWB to better match the existing counters naming > scheme. > > Suggested-by: Johannes Weiner <hannes@xxxxxxxxxxx> > Signed-off-by: Nhat Pham <nphamcs@xxxxxxxxx> > --- > include/linux/vm_event_item.h | 2 +- > mm/memcontrol.c | 2 +- > mm/vmstat.c | 2 +- > mm/zswap.c | 4 ++-- > 4 files changed, 5 insertions(+), 5 deletions(-) > > diff --git a/include/linux/vm_event_item.h b/include/linux/vm_event_item.h > index f4569ad98edf..747943bc8cc2 100644 > --- a/include/linux/vm_event_item.h > +++ b/include/linux/vm_event_item.h > @@ -142,7 +142,7 @@ enum vm_event_item { PGPGIN, PGPGOUT, PSWPIN, PSWPOUT, > #ifdef CONFIG_ZSWAP > ZSWPIN, > ZSWPOUT, > - ZSWP_WB, > + ZSWPWB, > #endif > #ifdef CONFIG_X86 > DIRECT_MAP_LEVEL2_SPLIT, > diff --git a/mm/memcontrol.c b/mm/memcontrol.c > index 21d79249c8b4..0286b7d38832 100644 > --- a/mm/memcontrol.c > +++ b/mm/memcontrol.c > @@ -703,7 +703,7 @@ static const unsigned int memcg_vm_event_stat[] = { > #if defined(CONFIG_MEMCG_KMEM) && defined(CONFIG_ZSWAP) > ZSWPIN, > ZSWPOUT, > - ZSWP_WB, > + ZSWPWB, > #endif > #ifdef CONFIG_TRANSPARENT_HUGEPAGE > THP_FAULT_ALLOC, > diff --git a/mm/vmstat.c b/mm/vmstat.c > index 2249f85e4a87..cfd8d8256f8e 100644 > --- a/mm/vmstat.c > +++ b/mm/vmstat.c > @@ -1401,7 +1401,7 @@ const char * const vmstat_text[] = { > #ifdef CONFIG_ZSWAP > "zswpin", > "zswpout", > - "zswp_wb", > + "zswpwb", > #endif > #ifdef CONFIG_X86 > "direct_map_level2_splits", > diff --git a/mm/zswap.c b/mm/zswap.c > index c65b8ccc6b72..0fb0945c0031 100644 > --- a/mm/zswap.c > +++ b/mm/zswap.c > @@ -761,9 +761,9 @@ static enum lru_status shrink_memcg_cb(struct list_head *item, struct list_lru_o > zswap_written_back_pages++; > > if (entry->objcg) > - count_objcg_event(entry->objcg, ZSWP_WB); > + count_objcg_event(entry->objcg, ZSWPWB); > > - count_vm_event(ZSWP_WB); > + count_vm_event(ZSWPWB); > /* > * Writeback started successfully, the page now belongs to the > * swapcache. Drop the entry from zswap - unless invalidate already > -- > 2.34.1 >