The second time is the charm, apologize for the noise.. resending it as plain-text On Thu, 30 Nov 2023 at 13:59, Liang Chen <liangchen.linux@xxxxxxxxx> wrote: > > Wrap code for checking if a page is a page_pool page into a > function for better readability and ease of reuse. > > Signed-off-by: Liang Chen <liangchen.linux@xxxxxxxxx> > Reviewed-by: Yunsheng Lin <linyunsheng@xxxxxxxxxx> > --- > net/core/skbuff.c | 7 ++++++- > 1 file changed, 6 insertions(+), 1 deletion(-) > > diff --git a/net/core/skbuff.c b/net/core/skbuff.c > index b157efea5dea..31e57c29c556 100644 > --- a/net/core/skbuff.c > +++ b/net/core/skbuff.c > @@ -890,6 +890,11 @@ static void skb_clone_fraglist(struct sk_buff *skb) > skb_get(list); > } > > +static bool skb_frag_is_pp_page(struct page *page) > +{ > + return (page->pp_magic & ~0x3UL) == PP_SIGNATURE; > +} > + That's fine, but why _frag? The same logic applies to non-fragmented pages no? So rename it to skb_from_pp()? [...] Thanks /Ilias