Re: [PATCH net-next v3 1/3] page_pool: Rename pp_frag_count to pp_ref_count

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2023/11/24 15:34, Liang Chen wrote:

>  static inline void page_pool_fragment_page(struct page *page, long nr)

It seems page_pool_fragment_page() might not be a appropriate name too?

Perhaps it might be better to grep defrag/frag to see if there is other
function name might need changing.

>  {
> -	atomic_long_set(&page->pp_frag_count, nr);
> +	atomic_long_set(&page->pp_ref_count, nr);
>  }
>  
> -static inline long page_pool_defrag_page(struct page *page, long nr)
> +static inline long page_pool_deref_page(struct page *page, long nr)

page_pool_defrag_page() related function is called by mlx5 driver directly,
we need to change it to use the new function too.

I assume that deref is short for dereference? According to:

https://stackoverflow.com/questions/4955198/what-does-dereferencing-a-pointer-mean-in-c-c

'dereferencing means accessing the value from a certain memory location
against which that pointer is pointing'.

So I am not sure if 'deref' is the right word here as I am not a native
english speaker, But it seems 'unref' is more appropriate here if we mirror
the napi_frag_unref() function name?




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux