Re: [PATCH RFC 01/12] mm/hugetlb: Export hugetlbfs_pagecache_present()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



You're (thankfully) not actually exporting anything, so please
don't claim that in the subject.

>  pte_t *huge_pmd_share(struct mm_struct *mm, struct vm_area_struct *vma,
>  		      unsigned long addr, pud_t *pud);
> +bool hugetlbfs_pagecache_present(struct hstate *h,
> +				 struct vm_area_struct *vma,
> +				 unsigned long address);

Can you just follow the much more readable two tab indent of the
function above?

> -static bool hugetlbfs_pagecache_present(struct hstate *h,
> -			struct vm_area_struct *vma, unsigned long address)
> +bool hugetlbfs_pagecache_present(struct hstate *h,
> +				 struct vm_area_struct *vma, unsigned long address)

Same here.  The new indentation not only is less readable but also
creates a pointlessly overlong line.





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux