[PATCH v3 0/5] mm: cleanup and use more folio in page fault

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Rename page_copy_prealloc() to folio_prealloc(), which is used by
more functions, also do more folio conversion in page fault.

v3:
- drop patch6 as Small-sized THP for anon will change anon allocation
- correct do_cow_page to do_cow_fault in subject and changlog
- add RB of Vishal

v2:
- add folio_test_large check in ksm_might_need_to_copy() and
  replace page->index to folio->index, per David, Matthew
- add RB of Sidhartha

Kefeng Wang (5):
  mm: ksm: use more folio api in ksm_might_need_to_copy()
  mm: memory: use a folio in validate_page_before_insert()
  mm: memory: rename page_copy_prealloc() to folio_prealloc()
  mm: memory: use a folio in do_cow_fault()
  mm: memory: use folio_prealloc() in wp_page_copy()

 include/linux/ksm.h |  4 ++--
 mm/ksm.c            | 39 ++++++++++++++++--------------
 mm/memory.c         | 58 +++++++++++++++++++++------------------------
 3 files changed, 50 insertions(+), 51 deletions(-)

-- 
2.27.0





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux