Re: [PATCH v2 2/2] mm/ksm: Test case for prctl fork/exec workflow

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



David Hildenbrand <david@xxxxxxxxxx> writes:

> On 20.09.23 21:01, Stefan Roesch wrote:
>> This adds a new test case to the ksm functional tests to make sure that
>> the KSM setting is inherited by the child process when doing a
>> fork/exec.
>> Signed-off-by: Stefan Roesch <shr@xxxxxxxxxxxx>
>> ---
>>   .../selftests/mm/ksm_functional_tests.c       | 67 ++++++++++++++++++-
>>   1 file changed, 66 insertions(+), 1 deletion(-)
>> diff --git a/tools/testing/selftests/mm/ksm_functional_tests.c
>> b/tools/testing/selftests/mm/ksm_functional_tests.c
>> index 901e950f9138..40b86c9caf3a 100644
>> --- a/tools/testing/selftests/mm/ksm_functional_tests.c
>> +++ b/tools/testing/selftests/mm/ksm_functional_tests.c
>> @@ -26,6 +26,7 @@
>>     #define KiB 1024u
>>   #define MiB (1024 * KiB)
>> +#define FORK_EXEC_CHILD_PRG_NAME "ksm_fork_exec_child"
>>     static int mem_fd;
>>   static int ksm_fd;
>> @@ -479,6 +480,65 @@ static void test_prctl_fork(void)
>>   	ksft_test_result_pass("PR_SET_MEMORY_MERGE value is inherited\n");
>>   }
>>   +static int ksm_fork_exec_child(void)
>> +{
>> +	/* Test if KSM is enabled for the process. */
>> +	int ksm = prctl(PR_GET_MEMORY_MERGE, 0, 0, 0, 0);
>> +	return ksm == 1;
>
> You can simply do "return prctl(PR_GET_MEMORY_MERGE, 0, 0, 0, 0) == 1;"
>
> Or maybe even "return prctl(PR_GET_MEMORY_MERGE, 0, 0, 0, 0);" and adjust the
> comparison below in the caller.
>

I'll use the first one, then its all in one place.

>> +}
>> +
>> +static void test_prctl_fork_exec(void)
>> +{
>> +	int ret, status;
>> +	pid_t child_pid;
>> +
>> +	ksft_print_msg("[RUN] %s\n", __func__);
>> +
>> +	ret = prctl(PR_SET_MEMORY_MERGE, 1, 0, 0, 0);
>> +	if (ret < 0 && errno == EINVAL) {
>> +		ksft_test_result_skip("PR_SET_MEMORY_MERGE not supported\n");
>> +		return;
>> +	} else if (ret) {
>> +		ksft_test_result_fail("PR_SET_MEMORY_MERGE=1 failed\n");
>> +		return;
>> +	}
>> +
>> +	child_pid = fork();
>> +	if (child_pid == -1) {
>> +		ksft_test_result_skip("fork() failed\n");
>> +		return;
>> +	} else if (child_pid == 0) {
>> +		char *prg_name = "./ksm_functional_tests";
>> +		char *argv_for_program[] = { prg_name, FORK_EXEC_CHILD_PRG_NAME };
>> +
>
> I'd simply have used the magic number "1" or so. But this works as well.
>

I think the current one makes it easier in case we have to add a second
one later.

> Reviewed-by: David Hildenbrand <david@xxxxxxxxxx>




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux