On Tue, Aug 15, 2023 at 09:54:36AM +0200, David Hildenbrand wrote: > On 15.08.23 05:26, Matthew Wilcox (Oracle) wrote: > > Stored in the first tail page's flags, this flag replaces the destructor. > > That removes the last of the destructors, so remove all references to > > folio_dtor and compound_dtor. > > > > Signed-off-by: Matthew Wilcox (Oracle) <willy@xxxxxxxxxxxxx> > > --- > > [...] > > > + /* Has a deferred list (may be empty). First tail page. */ > > + PG_deferred_list = PG_reclaim, > > + > > If PG_deferred_list implies thp (and replaces the thp dtor), should we > rather name this PG_thp or something along those lines? We're trying to use 'thp' to mean 'a folio which is pmd mappable', so I'd rather not call it that. > The sequence of > > if (folio_test_deferred_list(folio)) > free_transhuge_folio(folio); > > Looks less clear to what we had before. I can rename that. How about if (folio_test_deferred_list(folio)) folio_remove_deferred(folio);