Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> writes: > On Tue, 18 Jul 2023 14:57:12 -0300 Jason Gunthorpe <jgg@xxxxxxxx> wrote: > >> On Tue, Jul 18, 2023 at 05:56:15PM +1000, Alistair Popple wrote: >> > diff --git a/include/asm-generic/tlb.h b/include/asm-generic/tlb.h >> > index b466172..48c81b9 100644 >> > --- a/include/asm-generic/tlb.h >> > +++ b/include/asm-generic/tlb.h >> > @@ -456,7 +456,7 @@ static inline void tlb_flush_mmu_tlbonly(struct mmu_gather *tlb) >> > return; >> > >> > tlb_flush(tlb); >> > - mmu_notifier_invalidate_range(tlb->mm, tlb->start, tlb->end); >> > + mmu_notifier_invalidate_secondary_tlbs(tlb->mm, tlb->start, tlb->end); >> > __tlb_reset_range(tlb); >> >> Does this compile? I don't see >> "mmu_notifier_invalidate_secondary_tlbs" ? Dang, sorry. The original rename was to that but then we added *_arch_* and I obviously missed some of the already renamed calls. > Seems this call gets deleted later in the series. > >> But I think the approach in this series looks fine, it is so much >> cleaner after we remove all the cruft in patch 4, just look at the >> diffstat.. > > I'll push this into -next if it compiles OK for me, but yes, a redo is > desirable please. Yep, will respin.