On Fri, 7 Jul 2023 at 19:40, Matthew Wilcox <willy@xxxxxxxxxxxxx> wrote: > > On Fri, Jul 07, 2023 at 07:36:20PM +0530, Pintu Agarwal wrote: > > On Fri, 7 Jul 2023 at 18:16, Matthew Wilcox <willy@xxxxxxxxxxxxx> wrote: > > > > > > On Fri, Jul 07, 2023 at 03:57:42PM +0530, Anshuman Khandual wrote: > > > > LGTM, cma->name is an identifying attribute for the region for which the allocation > > > > request was made. But how about using cma_get_name() helper instead ? Very few call > > > > sites have been using the helper. > > > > > > It's not really a "helper", is it? The function name is longer than > > > its implementation. > > > > > > cma_get_name(cma) > > > vs > > > cma->name > > > > > > Plus there's the usual question about whether a "got" name needs to be > > > "put" (does it grab a refcount?) > > > > > > I think it's useful that this function exists since it lets us not expose > > > struct cma outside of mm/, but it really should be called cma_name() > > > and I don't think we should be encouraging its use within cma.c. > > > > Also, cma_get_name() is a trivial assignment. > > And in one of the previous patches we avoided function calls with > > trivial assignments. > > https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/kernel/dma/contiguous.c?h=next-20230705&id=5af638931eb374aa0894d8343cee72f50307ef20 > > dma-contiguous: remove dev_set_cma_area > > > > One more question from here: > > pr_debug("%s(cma %p, name: %s, count %lu, align %d)\n", __func__, > > (void *)cma, cma->name, count, align); > > > > Do we really need this "cma %p" printing ? > > I hardly check it and simply rely on name and count. > > Printing pointers is almost always a bad idea. Printing the base_pfn > might be a good idea to distinguish CMAs which happen to have the > same name? > No there is no name there, it's just a ptrval cma: cma_alloc(cma (ptrval), name: reserved, count 64, align 6)