Re: [PATCH v5 RESEND 09/17] openrisc: mm: Convert to GENERIC_IOREMAP

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 05/16/23 at 09:49am, Mike Rapoport wrote:
> Hi,
> 
> On Mon, May 15, 2023 at 05:08:40PM +0800, Baoquan He wrote:
> > By taking GENERIC_IOREMAP method, the generic generic_ioremap_prot(),
> > generic_iounmap(), and their generic wrapper ioremap_prot(), ioremap()
> > and iounmap() are all visible and available to arch. Arch needs to
> > provide wrapper functions to override the generic versions if there's
> > arch specific handling in its ioremap_prot(), ioremap() or iounmap().
> > This change will simplify implementation by removing duplicated codes
> > with generic_ioremap_prot() and generic_iounmap(), and has the equivalent
> > functioality as before.
> > 
> > Here, add wrapper function iounmap() for openrisc's special operation
> > when iounmap().
> > 
> > Signed-off-by: Baoquan He <bhe@xxxxxxxxxx>
> > Cc: Stafford Horne <shorne@xxxxxxxxx>
> > Cc: Jonas Bonn <jonas@xxxxxxxxxxxx>
> > Cc: Stefan Kristiansson <stefan.kristiansson@xxxxxxxxxxxxx>
> > Cc: openrisc@xxxxxxxxxxxxxxxxxxxx
> > ---
> >  arch/openrisc/Kconfig          |  1 +
> >  arch/openrisc/include/asm/io.h | 11 +++++---
> >  arch/openrisc/mm/ioremap.c     | 46 +---------------------------------
> >  3 files changed, 9 insertions(+), 49 deletions(-)
> > 
> > diff --git a/arch/openrisc/Kconfig b/arch/openrisc/Kconfig
> > index c7f282f60f64..fd9bb76a610b 100644
> > --- a/arch/openrisc/Kconfig
> > +++ b/arch/openrisc/Kconfig
> > @@ -21,6 +21,7 @@ config OPENRISC
> >  	select GENERIC_IRQ_PROBE
> >  	select GENERIC_IRQ_SHOW
> >  	select GENERIC_PCI_IOMAP
> > +	select GENERIC_IOREMAP
> >  	select GENERIC_CPU_DEVICES
> >  	select HAVE_PCI
> >  	select HAVE_UID16
> > diff --git a/arch/openrisc/include/asm/io.h b/arch/openrisc/include/asm/io.h
> > index ee6043a03173..e640960c26c2 100644
> > --- a/arch/openrisc/include/asm/io.h
> > +++ b/arch/openrisc/include/asm/io.h
> > @@ -15,6 +15,8 @@
> >  #define __ASM_OPENRISC_IO_H
> >  
> >  #include <linux/types.h>
> > +#include <asm/pgalloc.h>
> > +#include <asm/pgtable.h>
> >  
> >  /*
> >   * PCI: We do not use IO ports in OpenRISC
> > @@ -27,11 +29,12 @@
> >  #define PIO_OFFSET		0
> >  #define PIO_MASK		0
> >  
> > -#define ioremap ioremap
> > -void __iomem *ioremap(phys_addr_t offset, unsigned long size);
> > -
> > +/*
> > + * I/O memory mapping functions.
> > + */
> >  #define iounmap iounmap
> > -extern void iounmap(volatile void __iomem *addr);
> > +
> > +#define _PAGE_IOREMAP (pgprot_val(PAGE_KERNEL) | _PAGE_CI)
> >  
> >  #include <asm-generic/io.h>
> >  
> > diff --git a/arch/openrisc/mm/ioremap.c b/arch/openrisc/mm/ioremap.c
> > index 90b59bc53c8c..9f9941df7d4c 100644
> > --- a/arch/openrisc/mm/ioremap.c
> > +++ b/arch/openrisc/mm/ioremap.c
> > @@ -22,49 +22,6 @@
> >  
> >  extern int mem_init_done;
> >  
> > -/*
> > - * Remap an arbitrary physical address space into the kernel virtual
> > - * address space. Needed when the kernel wants to access high addresses
> > - * directly.
> > - *
> > - * NOTE! We need to allow non-page-aligned mappings too: we will obviously
> > - * have to convert them into an offset in a page-aligned mapping, but the
> > - * caller shouldn't need to know that small detail.
> > - */
> > -void __iomem *__ref ioremap(phys_addr_t addr, unsigned long size)
> > -{
> > -	phys_addr_t p;
> > -	unsigned long v;
> > -	unsigned long offset, last_addr;
> > -	struct vm_struct *area = NULL;
> > -
> > -	/* Don't allow wraparound or zero size */
> > -	last_addr = addr + size - 1;
> > -	if (!size || last_addr < addr)
> > -		return NULL;
> > -
> > -	/*
> > -	 * Mappings have to be page-aligned
> > -	 */
> > -	offset = addr & ~PAGE_MASK;
> > -	p = addr & PAGE_MASK;
> > -	size = PAGE_ALIGN(last_addr + 1) - p;
> > -
> > -	area = get_vm_area(size, VM_IOREMAP);
> > -	if (!area)
> > -		return NULL;
> > -	v = (unsigned long)area->addr;
> > -
> > -	if (ioremap_page_range(v, v + size, p,
> > -			__pgprot(pgprot_val(PAGE_KERNEL) | _PAGE_CI))) {
> > -		vfree(area->addr);
> > -		return NULL;
> > -	}
> > -
> > -	return (void __iomem *)(offset + (char *)v);
> > -}
> > -EXPORT_SYMBOL(ioremap);
> > -
> >  void iounmap(volatile void __iomem *addr)
> >  {
> >  	/* If the page is from the fixmap pool then we just clear out
> 
> The page cannot be from fixmap pool since we removed fixmap support from
> ioremap in an earlier patch.
> I believe that patch should also remove special casing of fixmap in
> iounmap() and then openrisc does not need to override any of ioremap
> methods.

Totally agree. I will clean it up in iounmap() in patch 3, and rearrange
this patch. Thanks again.

> 
> > @@ -88,9 +45,8 @@ void iounmap(volatile void __iomem *addr)
> >  		return;
> >  	}
> >  
> > -	return vfree((void *)(PAGE_MASK & (unsigned long)addr));
> > +	generic_iounmap(addr);
> >  }
> > -EXPORT_SYMBOL(iounmap);
> >  
> >  /**
> >   * OK, this one's a bit tricky... ioremap can get called before memory is
> > -- 
> > 2.34.1
> > 
> > 
> 
> -- 
> Sincerely yours,
> Mike.
> 





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux